This mod completely gets rid of the randomness of enchanting and allows you to pick what YOU want on your tools! It is. It will register enchantments that other mods add and will show up for the appropriate tool.

Recipes:
Advanced Enchantment Table:
http://aesireanempire.com/wiki/images/6/6e/AdvancedEnchantmentTable.png

Enchantment Table Upgrade:
http://aesireanempire.com/wiki/images/8/86/EnchantmentTableUpgrade.png


Comments

  • #53 CyanideX

    Hey! Just wanted to check in and see if you still had plans to use this! ;)

  • #52 SnuggleBunny

    I can`t download any Mods because this computer has had lots of Virisises and My mom and dad  are scared that it will get a Virious Does it give you any viriouses??

     

  • #54 Reddeh

    No.

  • #49 redDragon761

    My minecraft crashes when i try to open it with the enchanting plus 1.6.4 mod

  • #47 nastkal

    Very good . But what i can do for install these

     

  • #55 Reddeh

    http://bit.ly/1uMXksu

     

  • #46 Africanz

    yea awesome!

  • #45 P3rf3ct_Zer0

    Do know if you wanted to know this but here is an error.

    [11:15:40] [Client thread/INFO] [eplus]: Initializing GUI Handler.
    [11:15:40] [Client thread/ERROR] [FML]: Detected an attempt by a mod FMLMod:eplus{1.7.10-3.0.1} to perform game activity during mod construction. This is a serious programming error.

  • #44 kwpugh

    Hello,

    I loaded up the new 3.0.1 version and I encountered a problem where the GUI does not show the name of the enchants when an item is placed inside.   You can still slide the bars across and enchant the item, but the names of which enchants you have selected do not show.

    Regards,

    Kevin

     

  • #43 kwpugh

    Hello,

    I have been having a problem with the 1.7.10 version.   There aren't any crashes, the table just won't enchant items when a player presses the "E" button with an item in the slot.   It won't even enchant basic vanilla items like a diamond sword or pickaxe.

    Strangely, it works perfectly fine if I'm in creative mod, just not in survival.

    If you need more info on the mods I'm running, let  me know.

    Regards,

    Kevin

     

  • #48 MrZoras

    Change your language to English. :)

  • #41 patchchristensen

    This mode is great and appears to work on 1.7.10 for the most part. Thanks for you work on it. Two things that I noticed. I know this is still beta version.

    Bow enchantments are crazy expensive

    Did the repair items get removed?

    Again keep up the good work and thanks.

     

  • #39 maodiaz2

    XCSDA

  • #35 ham_slam

    hello,

        i have been trying to get all mods like this but when i drag a mod to the "mod" folder and launch minecraft, it crashes my minecraft please help me out with this problem. Many people says it's because of the version, i've tried 1.7.2, 1.5.2, and 1.6.2. I dont know what to do, please let me know whats wrong.

                          sincerely, ham_slam

  • #40 inkdrgn

    Make sure you have the correct version of forge for that version of minecraft. Make sure you have the correct version of the mod for that version of minecraft. Eg: for Minecraft 1.6.4 you should have forge 9.11.1.965, and Enchanting Plus 1.16.5. 

     

    Install forge, put the mod in the mod folder and launch minecraft with the forge profile.

  • #34 SimtropBuggi

    Please update to 1.7.10, this is such an essential mod to my gameplay.

  • #33 JaedenRuiner

    Hello,

    Just got into enchanting in Minecraft, and frankly do not agree with the idea of spending XP on whatever random.  So I found this mod, everything looks perfect about it, but I can't get it to work (crashes Minecraft).  

    I'm a little noob to the whole minecraft thing, but definitely enjoy the game and having fun at it.
    what I know that will help is when i run the Minecraft launcher, it says in the bottom riight:

    ready to play Minecraft 1.7.10
        or
    ready to play Minecraft 1.7.10-Forge10.13.0.1180

    dependent on profile.  This mod says it is 1.7.2 compatible.  Is that it, or will an update be coming out to adjust to the new version of minecraft? Is there a way that I can roll my minecraft back to a compatible version without losing my current "world"?

    Thanks

    Jaeden "Sifo Dyas" al'Raec Ruiner

  • #27 SimtropBuggi

    Still can't enchant shears using latest forge 1126.

  • #26 SimtropBuggi

    Unable to enchant shears using EPlus table. :(

    Forge 1107, MC 1.7.2

  • #38 SimtropBuggi

    Shears are enchantable, you just have to use the anvil and enchanted books.

  • To post a comment, please or register a new account.
Posts Quoted:
Reply
Clear All Quotes