• 0

    posted a message on Skipping Entity with id...

    Hey guys!

     

    I'm struggling with a Minecraft modpack.

    Essentially, I try use a spawn egg for mobs from a few mods and they spawn invisible.

     

    They make sound, you can 'push' them, but they don't have a hitbox and are invisible.

     

    The log just says

    ```[15:28:21] [Client thread/INFO]: Server attempted to spawn an unknown entity using ID: {0} at ({1}, {2}, {3}) Skipping!
    [15:28:21] [Client thread/WARN]: Skipping Entity with id -47```


    There's a full log here:
    https://pastebin.com/ENWYmShT
    Any help appreciated!

    Hi, just decompiled the class files and I found it's using the global entity ID system, could this be a problem?

     

        int Pirate1ID = EntityRegistry.findGlobalUniqueEntityId();
        EntityRegistry.registerGlobalEntityID(EntityPirate.class, "Pirate1", Pirate1ID);
        
        createEgg(Pirate1ID, 16777215, 0);
        
        int Pirate2ID = EntityRegistry.findGlobalUniqueEntityId();
        EntityRegistry.registerGlobalEntityID(EntityPirate1.class, "Pirate2", Pirate2ID);
        
        createEgg(Pirate2ID, 16777215, 0);
        
        int Pirate3ID = EntityRegistry.findGlobalUniqueEntityId();
        EntityRegistry.registerGlobalEntityID(EntityPirate2.class, "Pirate3", Pirate3ID);
        
        createEgg(Pirate3ID, 16777215, 0);
        
        int GhostPirateID = EntityRegistry.findGlobalUniqueEntityId();
        EntityRegistry.registerGlobalEntityID(EntityGhostPirate.class, "GhostPirate", GhostPirateID);

    Posted in: Non-CurseForge Modpacks
  • To post a comment, please or register a new account.