• 0

    posted a message on Problem with textures

    Im new minecraft modder,and i have problem with textures.I made block and added texture for block in assets/Experiment/textures/blocks/bestblockever .I ve tried to change type(png or jpg),to change names and other stuff.Idk what is problem.And reloaded eclipse

    Why it doesnt see texture?

    Main:

    
    import cpw.mods.fml.common.Mod;
    import cpw.mods.fml.common.Mod.EventHandler;
    import cpw.mods.fml.common.event.FMLPreInitializationEvent;
    import cpw.mods.fml.common.registry.GameRegistry;
    import net.minecraft.block.Block;
    import net.minecraft.block.material.Material;
    import net.minecraft.creativetab.CreativeTabs;
    import net.minecraft.init.Blocks;
    import net.minecraft.item.Item;
    
    @Mod(modid = Main.MODID, name = Main.MODNAME, version = Main.VERSION)
    public class Main {
               
    	public static final CreativeTabs tabExperiment = new CreativeTabs("Experiment") {
    		public Item getTabIconItem() {
    			return Item.getItemFromBlock(Blocks.diamond_ore);
    		}
    	};
    	
    	
    	
    	public static final String MODID = "Experiment";
    	public static final String MODNAME = "ExperimentName";
     	public static final String VERSION = "1.1.0";
     	
     	public static Block experimentBlock;
    
    
     	@EventHandler
     	public void preInit(FMLPreInitializationEvent event) {
     	 	experimentBlock = new ExperimentBlocks(Material.rock, "experimentBlock", "experimentBlock");
     	 	GameRegistry.registerBlock(experimentBlock, "experimentBlock");
     	}
     	
    	
    	
    <em><strong>ExperimentBlocks:</strong></em>
    
    
    
    import net.minecraft.block.Block;
    import net.minecraft.block.material.Material;
    
    public class ExperimentBlocks extends Block {
    
    	protected ExperimentBlocks(Material p_i45394_1_, String name, String texture) {
    		super(p_i45394_1_);		
    		// TODO Auto-generated constructor stub
    		this.setBlockName(name);
    		this.setBlockTextureName(Main.MODID+":"+texture);
    		this.setHardness(2.0F);
    		this.setHarvestLevel("pickaxe", 2);
    		this.setCreativeTab(Main.tabExperiment);
    		this.setResistance(10F);
    		this.setLightLevel(40F);
    		
    		
    	}
    
    }
    
    <em><strong>Crash log</strong></em>
    [21:13:42] [Client thread/ERROR] [TEXTURE ERRORS]: +=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=
    [21:13:42] [Client thread/ERROR] [TEXTURE ERRORS]: The following texture errors were found.
    [21:13:42] [Client thread/ERROR] [TEXTURE ERRORS]: ==================================================
    [21:13:42] [Client thread/ERROR] [TEXTURE ERRORS]:   DOMAIN experiment
    [21:13:42] [Client thread/ERROR] [TEXTURE ERRORS]: --------------------------------------------------
    [21:13:42] [Client thread/ERROR] [TEXTURE ERRORS]:   domain experiment is missing 1 texture
    [21:13:42] [Client thread/ERROR] [TEXTURE ERRORS]:     domain experiment is missing a resource manager - it is probably a side-effect of automatic texture processing
    [21:13:42] [Client thread/ERROR] [TEXTURE ERRORS]: -------------------------
    [21:13:42] [Client thread/ERROR] [TEXTURE ERRORS]:     The missing resources for domain experiment are:
    [21:13:42] [Client thread/ERROR] [TEXTURE ERRORS]:       textures/blocks/experimentBlock.png
    [21:13:42] [Client thread/ERROR] [TEXTURE ERRORS]: -------------------------
    [21:13:42] [Client thread/ERROR] [TEXTURE ERRORS]:     No other errors exist for domain experiment
    [21:13:42] [Client thread/ERROR] [TEXTURE ERRORS]: ==================================================
    [21:13:42] [Client thread/ERROR] [TEXTURE ERRORS]: +=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=
    
    
    
     

     

    Posted in: Mod Development
  • To post a comment, please or register a new account.