• 0

    posted a message on Mac OS is not working with CurseForge... Mods won't load

    Recently I tried to download a new modpack: FTB revelations, and still after one year, forge is still forcing me to use the legacy launcher, which doesn't have minecraft 1.12, which is needed for Revelations. Why has there not been a fix for this after a YEAR... 

    Posted in: Support
  • To post a comment, please or register a new account.