• 0

    posted a message on Allocating RAM to FTB Ultimate Reloaded Server with No Effect

    Wound up fixing the problem myself. I removed the original ServerStart.bat and settings.bat files and made a new ServerStart.bat file that only included the below text:

    java -Xmx8196M -Xms4096M -jar FTBserver-1.12.2-14.23.5.2838-universal.jar

    The GUI now shows that I have much more RAM available, and my average tick rate is down from 30 ms to around 5 ms. I have random spikes here and there, but pretty uncommon. Overall the server is very playable so the problem seems to be (mostly) fixed.

    Posted in: Support
  • 0

    posted a message on Allocating RAM to FTB Ultimate Reloaded Server with No Effect

    Hi all. I've searched for similar threads without being able to find a fix, so I'm hoping someone can offer advice. I've installed a new server for FTB Ultimate Reloaded 1.8.0. I'm trying to allocate more RAM to the server as it's lagging quite a bit, and my GUI shows it's using ~512 MB with 1% additional RAM free. However, I've already gone into the settings.bat file and changed the text as follows:

    rem can be changed by user
    set MAX_RAM=8G
    set JAVA_PARAMETERS=-XX:+UseParNewGC -XX:+CMSIncrementalPacing -XX:+CMSClassUnloadingEnabled -XX:ParallelGCThreads=5 -XX:MinHeapFreeRatio=5 -XX:MaxHeapFreeRatio=10

    As far as I can tell, the ServerStart.bat file defaults to the parameters set in the settings.bat file as indicated by the below text:

    @if NOT "%FTB_VERBOSE%"=="yes" (
    @echo off
    )
    call settings.bat

    and defines the max ram using this definition which matches up with the settings.bat file:

    :startserver
    echo Starting server
    java -server -Xmx%MAX_RAM% -XX:PermSize=%PERMGEN_SIZE% %JAVA_PARAMETERS% -jar %FORGEJAR%

    So why, when the settings.bat file has been updated with a max ram size of 8G, am I still showing that there's only 1% of available RAM free in the GUI when it's only using 512 MB and I have significant tick lag? I'm still very new to this stuff and have zero experience with reading actual code so I may be misunderstanding something. Any help is greatly appreciated and I'm sorry if this has been solved elsewhere - I tried searching for it. I've tried posting a few other places (Reddit, FTB forums) and no one has even responded within the last few days. 

    Posted in: Support
  • To post a comment, please or register a new account.