CompatLayer

This small mod/library has some tools that can help to make mods binary compatible between 1.10 and 1.11. If you make sure you use the api in this mod correctly it is possible to make a mod jar that runs on both versions.

 

A few things that you should do in addition to what this library does:

 

  • Make all resource names (lang files, model names, json files, texture files, ...) lower case in your 1.10.2 version. Add a FMLMissingMapping event handler to take care old worlds load
  • Mod id should be lowercase too
  • Replace tileEntity.worldObj with tileEntity.getWorld()
  • Replace entityPlayer.worldObj with entityPlayer.getEntityWorld()

This is alpha. It is likely things are not complete yet.

 

Wiki for more information: https://github.com/McJty/compatlayer/wiki

Tutorial for modders: http://modwiki.temporal-reality.com/mw/index.php?title=CompatLayer-1.11

Maven for 1.10.2: http://jenkins.k-4u.nl/view/McJty/job/Compatlayer%201.10/

Maven for 1.11: http://jenkins.k-4u.nl/view/McJty/job/Compatlayer%201.11/

 

About This Project

  • Project ID
    253729
  • Created
    Nov 17, 2016
  • Last Released File
    May 23, 2017
  • Total Downloads
    3,933,042
  • License

Categories

Members